Posts Tagged ‘ADFS’

Time to perform your TLS Version Check | Goodbye TLS1.0 and TLS 1.1 protocols

Wednesday, August 21st, 2019

A vulnerability named POODLE was discovered in SSL 3.0. POODLE or Padded Oracle On Downgraded Legacy Encryption that gave a blow to cloud security. Last year, Microsoft had finally taken the decision to turn off the support for all TLS protocols older than TLS 1.2 and SSL v3 last for better cloud security. A decision that was taken to protect systems against similar POODLE attacks as in the past. It wasn’t easy to get rid of TLS 1.1 and TLS 1.0 so soon, most Microsoft OS and applications had these two protocols hardcoded for a better interoperability experience. Microsoft had to face a bitter backlash as most organizations weren’t ready for the “Change” in its attempt to improve cloud security.

READ MORE →